simple routeros hotspot setup

A simple hotspot how-to

The simple hotspot setup described here is used as an extra authentication and accounting method along with wpa2 pre-shared keys.

I assume that the router is connected already to your WAN(s).
In my case the WAN(s) are the AWMN with BGP and the Internet with static routes.

Test connectivity:
[ipduh@rock] /ip> /ping ipduh.com
HOST                                     SIZE TTL TIME  STATUS                                                                                     
85.25.242.245                              56  49 63ms 
85.25.242.245                              56  49 64ms 
85.25.242.245                              56  49 63ms 
    sent=3 received=3 packet-loss=0% min-rtt=63ms avg-rtt=63ms max-rtt=64ms 

[ipduh@rock] /ip> /ping www.awmn
HOST                                     SIZE TTL TIME  STATUS                                                                                     
10.19.143.13                               56  57 11ms 
10.19.143.13                               56  57 5ms  
10.19.143.13                               56  57 25ms 
10.19.143.13                               56  57 10ms 
    sent=4 received=4 packet-loss=0% min-rtt=5ms avg-rtt=12ms max-rtt=25ms 



Set wireless:
/interface wireless set wlan1 ssid=hotspot.ipduh.net band=2ghz-b/g/n \
\... mode=ap-bridge
etc

Set the wireless interface ip address
/ip address add address=192.168.8.1/24 interface=wlan1


Set the hotspot
 /ip hotspot setup
Select interface to run HotSpot on 

hotspot interface: wlan1
Set HotSpot address for interface 

local address of network: 192.168.8.1/24
masquerade network: yes
Set pool for HotSpot addresses 

address pool of network: 192.168.8.10-192.168.8.250
Select hotspot SSL certificate 

select certificate: none                    
Select SMTP server 

ip address of smtp server: 0.0.0.0
Setup DNS configuration 

dns servers: 10.21.241.4
DNS name of local hotspot server 

dns name: hotspot.ipduh.net



Add a Hotspot User
/ip hotspot user add name=surfer password=opensesami


κομπλεdone!

You should be able to login by connecting to the if with SSID hotspot.ipduh.net supplying the key if enabled and get your IP and DNS settings from the DHCP server. Once you fireup a browser you will be redirected to hotspot.ipduh.net --a DNS-hijacked authorization website running on 192.168.8.1.



Simple RouterOS Hotspot Setup